Après windows pour les nuls, voici PB pour les bons (ou presque).

Le forum (ô combien francophone) des utilisateurs de Powerbuilder.

Recherche rapide

Annonce

Certaines rubriques, dont des cours, sont uniquement visibles par les membres du forum ^^.
Dans la rubrique Liens & Références, vous avez accès à un sommaire de téléchargement, profitez-en !
Il existe maintenant un nouveau TOPIC "Votre CV en Ligne" accessible uniquement par demande.

#1 12-03-2014 09:32:21

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Compatibilit PB 11.5 PB 12.5

Bonjour,

Je dois maintenir une application de GMAO (Amos Spectec) développée sous PB 11.5. Je précise je suis absolument débutant en PB mais peut importe je n'ai que des modifs mineures à réaliser comme des modification de rapports contenus dans des bibliothèques PBL.

Le hic est le suivant : j'arrive bien a éditer mes rapport sous PB 12.5 , la preview marche impeccable. Quand j’intègre le fichier pbl modifié dans l'appli elle plante. Je suppose qu'il y a un soucis de compatibilité.

Y a til un moyen de travailler avec une version PB 12.5 et de rester en mode de compatibilité 11.5.

OU dois je tout simplement acheter une version 11.5 si elle est trouvable (

merci beaucoup pour votre aide

Hors ligne

 

#2 12-03-2014 09:54:04

buck  
Modérateur
Lieu: Dijon
Date d'inscription: 31-07-2008
Messages: 745
Pépites: 1,028,837
Banque: 171,170,849,654

Re: Compatibilit PB 11.5 PB 12.5

Bonjour,

A ma connaissance ce n'est pas possible, pourquoi ne pas migrer totalement l'application en 12.5 ? il ne doit pas avoir de difficultés particulières le gap entre les 2 versions n'est pas important.

Hors ligne

 

#3 12-03-2014 10:17:03

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

Bonjour merci pour cette réponse rapide,

nous ne pouvons pas  migrer l'application car elle ne nous appartient pas et nous n'avons pas les sources malheureusement. nous avons un contrat de maintenance chez l’éditeur mais pour des raisons économiques on aimerait personnaliser les rapports nous mêmes.


et powerbuilder 11.5 ?

merci
@bientôt

Hors ligne

 

#4 12-03-2014 10:23:30

erasorz  
Admin
Lieu: Babylone
Date d'inscription: 23-11-2006
Messages: 5121
Pépites: 97,197
Banque: 2,147,483,647

Re: Compatibilit PB 11.5 PB 12.5

Je ne comprends pas...
Tu dis que tu n'as pas les sources et que tu modifies les PBL. Or les PBL sont les sources justement.


N'envoyez jamais un humain faire le travail d'un programme.

Hors ligne

 

#5 12-03-2014 10:30:27

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

les pbl que j'ai ne contienne que des rapports. les interfaces utilisateurs codes etc   doivent être dans des fichier pbd je suppose mais je précise je débute en PB. J'ai compris que le click droit build compilait les pbl pour en faire des pbd

Hors ligne

 

#6 12-03-2014 10:35:18

erasorz  
Admin
Lieu: Babylone
Date d'inscription: 23-11-2006
Messages: 5121
Pépites: 97,197
Banque: 2,147,483,647

Re: Compatibilit PB 11.5 PB 12.5

Ah ok
Tu peux télécharger PowerBuilder 11.5 (normalement avec une licence 12.5 tu y auras accès) -> https://sybase.subscribenet.com


N'envoyez jamais un humain faire le travail d'un programme.

Hors ligne

 

#7 12-03-2014 10:53:42

pick ouic  
La bourse ou la vie ^^
Award: gearotter
Lieu: Massy-Verrières
Date d'inscription: 29-05-2006
Messages: 4642
Pépites: 897
Banque: 2,147,483,647
Site web

Re: Compatibilit PB 11.5 PB 12.5

erasorz a écrit:

Ah ok
Tu peux télécharger PowerBuilder 11.5 (normalement avec une licence 12.5 tu y auras accès) -> https://sybase.subscribenet.com

ok pour le telechargement, mais pas sur que tu reussises à obtenir une licence valide. (tant mieux si tu y arrives !)


Connaitre son ignorance est une grande part de la connaissance.
http://animegifs.free.fr/anime/mazinger/mazinger.gif

Hors ligne

 

#8 12-03-2014 11:04:12

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

ok merci
je vais essayer

je vous tiens au courant dès que j ai pu avoir cette  version.

@ bientôt

Hors ligne

 

#9 12-03-2014 11:04:51

erasorz  
Admin
Lieu: Babylone
Date d'inscription: 23-11-2006
Messages: 5121
Pépites: 97,197
Banque: 2,147,483,647

Re: Compatibilit PB 11.5 PB 12.5

pick ouic a écrit:

mais pas sur que tu reussises à obtenir une licence valide. (tant mieux si tu y arrives !)

pourquoi ?


N'envoyez jamais un humain faire le travail d'un programme.

Hors ligne

 

#10 19-03-2014 08:48:31

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

Hello,

impossible d'avoir un contact chez SAP

J'avais fait mes essais avec la version trial téléchargeable.

Avez des adresses de revendeurs ?

merci beaucoup

Hors ligne

 

#11 19-03-2014 09:16:31

Dadone  
Membre Power Geek
Lieu: Avon (Seine et Marne)
Date d'inscription: 19-02-2007
Messages: 252
Pépites: 985
Banque: 0
Site web

Re: Compatibilit PB 11.5 PB 12.5

ronybris a écrit:

Hello,

impossible d'avoir un contact chez SAP

J'avais fait mes essais avec la version trial téléchargeable.

Avez des adresses de revendeurs ?

merci beaucoup

Demandes à la société Novalys

Hors ligne

 

#12 19-03-2014 10:06:01

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

ok merci je vais envoyer un mail bonne journee

Hors ligne

 

#13 19-03-2014 16:19:24

Yanis  
Modérateur
Lieu: paris
Date d'inscription: 16-06-2010
Messages: 349
Pépites: 665
Banque: 150

Re: Compatibilit PB 11.5 PB 12.5

Salut,

     As tu essayé cette addresse pour prendre contact avec les personnes en charges des produits Sybase

         http://www.sybase.com/products/modeling … werbuilder


Cdt
Yanis

Hors ligne

 

#14 28-03-2014 09:15:33

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

Bonjour à tous,

et bien c'est pas gagné tout ça. Visiblement l'obtention d'une licence 11.5 va être coton d'après les quelques contacts que j'ai eu. Je vais devoir trouver une version d'occaze, si quelqu'un veut bien me vendre la sienne en attendant que l’éditeur de mon logiciel migre son appli en 12.5.2.

@ bientôt et bon week end

Hors ligne

 

#15 28-03-2014 09:39:06

patrick_remy  
Membre
Lieu: bruxelles
Date d'inscription: 28-05-2008
Messages: 13
Pépites: 39
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

Je suis capable de faire un reverse engenering des pbd, dll, exe de la version 11.5.
Même le nom des variables et des fonctions sera ceux d'origine (mis à part les commentaires qui eux sont perdus).

Hors ligne

 

#16 28-03-2014 12:14:38

seki  
0x73656B69
Award: bf
Lieu: Laquenexy & Luxembourg
Date d'inscription: 20-11-2008
Messages: 1116
Pépites: 4,296,080,198
Banque: 9,223,372,036,854,776,000
Site web

Re: Compatibilit PB 11.5 PB 12.5

patrick_remy a écrit:

Je suis capable de faire un reverse engenering des pbd, dll, exe de la version 11.5.

C'est marrant le nombre des dev PB qui ont fini par aller voir comment ça se passait sous le capot...
Moi je ne sais pas encore démonter complètement les classes compilées


The best programs are the ones written when the programmer is supposed to be working on something else. - Melinda Varian

Mes réponses PB sur StackOverflow
http://stackoverflow.com/users/flair/317266.png

Hors ligne

 

#17 02-06-2014 12:50:27

ronybris  
Membre
Date d'inscription: 04-03-2014
Messages: 10
Pépites: 44
Banque: 0

Re: Compatibilit PB 11.5 PB 12.5

Bonjour à tous,

désolé pour l'absence d'information.

Donc, mon éditeur est venu nous voir avec une version 11.5 et visiblement c'est la seule façon de modifier nos éditions de rapports en attendant qu'ils migrent leur logiciel en 12.5 et là nous aurons un outil. La version 11.5 n'est visiblement plus disponible du tout.

Bonne journée
Ronan

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB 1.2.22