Quoi, tu ne connais pas PB ? Va falloir parcourir tout le forum alors !

Le forum (ô combien francophone) des utilisateurs de Powerbuilder.

Recherche rapide

Annonce

Certaines rubriques, dont des cours, sont uniquement visibles par les membres du forum ^^.
Dans la rubrique Liens & Références, vous avez accès à un sommaire de téléchargement, profitez-en !
Il existe maintenant un nouveau TOPIC "Votre CV en Ligne" accessible uniquement par demande.

#1 22-11-2011 10:56:09

jcc  
Membre completement Geek
Lieu: Mouscron
Date d'inscription: 08-01-2008
Messages: 142
Pépites: 13,733
Banque: 409,387,083,524

Problème de Postback mais pas sûr!

Bonjour,
Nous avons développé une application de gestion de congés.
Certains utilisateurs nous signalent un comportement bizarre de la dataswindow de demande congé.
Lorsqu'ils encodent date et heure de début et date et heure de fin ou autre, il arrive que le refresh de la datawindow vide les champs déjà encodés.
Il est vrai que les champs sont affichés en fonction du type de congé choisi dans une dropdowndatawindow pour lequel nous avons un itemchanged event ce qui génère un postback.
On pourrait penser que le problème vient de là.
Mais, nous, développeurs, n'avons pas ce comportement bizarre et nous n'arrivons pas à le reproduire. Tout fonctionne correctement aussi bien en utilisant l'application à partir de notre environnement de développement que dans l'environnement de production.
Nous remarquons bien qu'il y a refresh de la datawindow dû à l'itemchanged event mais les données introduites sont toujours visibles et que si nous mettons en remarque le code de l'itemchanged event, le refresh ne se fait pas.
Nous pourrions trouver une alternative à l'itemchanged mais nous ne sommes pas certain que l'origine du problème émane de là étant donné qu'il est impossible de reproduire ce comportement chez nous où tout ce passe bien.

Pourriez-vous nous aider à trouver une solution?
Pourquoi cela arrive chez ces utilisateurs et pas chez nous?

Après sondage, chez certains utilisateurs, le fait de sortir de l'application et de la relancer règle le problème même si cela est génant. Pour d'autre, relancer le programme ne change rien à ce comportement bizarre d'autant plus que cela peut fonctionner pendant plusieurs jours et puis soudain...

Pourquoi cela ne se passe-t'il pas toujours?

Merci d'avance de votre aide car nous ne savons pas dans quelle direction effectuer nos recherches.

Jcc

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB 1.2.22